Whitenoise: Gizmodo Community Talkback

Welcome to Whitenoise, where you can come to talk about anything you want with other Gizmodo readers. Want to ask the Giz editors a question? Pop in and let the community know!

A new week, a new thread. Feel free to take the conversation anywhere you like. Create some whitenoise by commenting below...


    Anyone know where I can hands on the Nokia Lumia 920 or Nexus 4 in Melbourne?

      Next week the Lumia 920 should be in Telstra, Harvey Norman and JB stores.

    Any chance of Gizmodo.com.au using their contacts to find out what is happening with the Galaxy S3 Jellybean update?

      Got my Ingress invite before I got an answer from Giz!

        Ok, I'll answer my own question; Vodafone say it'll be rolled out on Monday 26th November.

    Please, please, please do not jump on the bandwagon of calling the galaxy note II a "phablet". News.com.au did it and almost made me throw up - http://www.news.com.au/technology/smartphones-push-for-christmas-rush/story-e6frfro0-1226519099942

      Giz has been calling these phones the size of your face phablets for a decent length of time now. News.com.au is the follower here, not the leader.

        Oh dear god

          It's just like mainstream media using the word Troll all the time. They have absolutely no idea what it means, but the nerds seem to use it, and it seems to be punchy!

            A troll is open to interpretation, a phablet is fairly open and shut. I think a lot of annoyance on Giz about the use of Troll by media is that it is a fear based moniker to drum up readers. A phablet is a new tech phenomenon and is a useful expression to describe large (and awesome) phones.

              There is no interpretation whatsoever around the definition of troll.

              Do you live under a bridge? Do you demand a fee for passage to those who trample over your home?

    OK Giz, I've asked this question a couple of times now and been completely ignored..
    I can't get the reply or edit to work at all. I've tried FF and Chrome, I've disabled add block and do not track, not sure what else to try here.. little help please..

      My suggestion is if you haven't already, is try emailing Danny Allen and tell him about your problem? There might be an error with your account that certain features of your account might be disabled for some reason.

        @luke @mdolley
        Thanks guys, seems to have mysteriously fixed itself.. Strange that, but grateful non the less :)

          Glad to hear that the problem solved itself in the end.

      I had an issue with a stuck notification. Used the report an error form and got it sorted pretty quickly. http://www.gizmodo.com.au/report-issue/

    Just thought I'd like to share my amazing achievement in Halo4 - I got a killtastrophe (8 consecutive kills in a time frame. Think double kill + 6) in a big team battle game. In all the Halo games I never got more than an overkill (4 kills). I'm greatly proud of this achievement :)... I also got a chance to finish the campaign, the story is quite good and 343 have done an amazing job at this. If anyone hasn't played it yet, I recommend watching the youtube movie "Halo4 - Forward unto Dawn". I watched it after playing the campaign, but it's actually a preface to the game and shows the relationship between Master Chief and Captain Lasky... The game play is very much following the classic halo style, with some nice surprises.

    You finally get to fly the pelican!

    OK, have I accidentally stood on someone's delicate sensibilities at Allure.?
    Less than a day after the problem got fixed and it was back!
    Once again I can't reply or edit, nothing! I've tried different browsers, I've tried turning addons off, nothing. I tried contacting staff, no reply. Considering no staff replied last time, I mentioned this in Whitenoise I can only assume it's an internal problem with 'Allure'. So whomever it was that I pissed off.. Sorry. If this is just a glitch, there must be some way to fix it.. little help please..!

      Apparently it works in Opera but not FF or Chrome, very strange...?

    Anyone upgraded their Galaxy Nexus from 4.1 to 4.2? I've had a few problems:
    1. Swift key stopped working and I had to download and reinstall
    2. My monthly pass for cricket streaming disappeared, but play store says I already have it.

    First time i've had trouble with an android update

Join the discussion!

Trending Stories Right Now